Dear Maintainer, I started Evolution, and attempted to download my mail from another of my e-mail addresses, which uses server vps-unixweb2.totalhostingplus.com. The status bar showed that it was fetching e-mail. I knew from experience that this meant that it was not fetching e-mail. After a while the following message apeared at the top of the window: 'Error while Fetching mail from “betham@”[DOMAINNAME].org.uk. Unable to connect to POP server vps-unixweb2.totalhostingplus.com. Error sending password: Broken pipe' The e-mail was not downloaded. I had hoped that my incoming e-mail would be downloaded. I surmise that, maybe, the system does not cope with a certificate chain of more than 2 certificates. I can fetch mail from the same server using getmail. I can also get mail form the same server using my old Apple iPad Air. My linux system, using Evolution works well with my main e-mail address, which is richard@betham.org.uk .