#1149531 ctdb: PID path problem. Ctdb fails to start

Package:
ctdb
Source:
ctdb
Description:
clustered database to store temporary data
Submitter:
Jani Heikkinen
Date:
2026-09-30 11:51:01 UTC
Severity:
normal
#1149531#5
Date:
2026-09-30 11:34:57 UTC
From:
To:
Dear Maintainer,
I installed in forky/sid the latest samba and ctdb packages.
After configuring minimum requirements for ctdb to start (node definition in /etc/ctdb),
ctdb fails to start with following error:
Sep 30 13:21:54 sid-box systemd[1]: ctdb.service - CTDB skipped, unmet condition check ConditionFileNotEmpty=/etc/ctdb/nodes
Sep 30 13:22:25 sid-box systemd[1]: Starting ctdb.service - CTDB...
Sep 30 13:22:25 sid-box ctdbd[3998]: CTDB starting on node
Sep 30 13:22:25 sid-box ctdbd[3998]: Cluster lock not set
Sep 30 13:22:25 sid-box ctdbd[3998]: Loading tunables from /etc/ctdb/ctdb.tunables
Sep 30 13:22:25 sid-box ctdbd[4000]: Starting CTDBD (Version 4.25.0-Debian-4.25.0+dfsg-1) as PID: 4000
Sep 30 13:22:25 sid-box ctdbd[4000]: Failed to create PID file /run/samba/ctdb/ctdbd.pid
Sep 30 13:22:25 sid-box systemd[1]: ctdb.service: Can't open PID file '/run/ctdb/ctdbd.pid' (yet?) after start: No such file or directory
Sep 30 13:23:55 sid-box systemd[1]: ctdb.service: start operation timed out. Terminating.
Sep 30 13:23:55 sid-box systemd[1]: ctdb.service: Failed with result 'timeout'.
Sep 30 13:23:55 sid-box systemd[1]: Failed to start ctdb.service - CTDB.

It seems like ctdbd binary tries to create a PID file /run/samba/ctdb/ctdbd.pid, whereas
ctdb systemd service looks for PID /run/ctdb/ctdbd.pid

I did short-term local fix by rewriting [Service] section for systemd service to point
same path and PID as the ctdbd binary.

Best, Jani Heikkinen

#1149531#10
Date:
2026-09-30 11:48:41 UTC
From:
To:
Control: tag -1 + confirmed pending

It looks like ctdb runtime dir moved from [/var]/run/ctdb/ to [/var]/run/samba/ctdb/,
which is somewhat unexpected.  This is commit e74f5f8269f42e8fd "ctdb-common: Add basic
path functionality for new directories", and subsequent changes.

Yeah.

I dunno if it was intentional or not, but here we go.   I'll adjust ctdb.service.

Thanks!

/mjt