#1153075 python3-zarr: fails to byte-compile on install

#1153075#5
Date:
2026-11-05 07:28:29 UTC
From:
To:
This is probably due to this version of zarr requiring Python >>3.15:

Setting up python3-zarr (3.4.2-1)…
Failed to byte-compile /usr/lib/python3/dist-packages/zarr/_compat.py:   File "/usr/lib/python3/dist-packages/zarr/_compat.py", line 18
    def _deprecate_positional_args[T](
                                  ^
SyntaxError: expected '('

Failed to byte-compile /usr/lib/python3/dist-packages/zarr/abc/codec.py:   File "/usr/lib/python3/dist-packages/zarr/abc/codec.py", line 46
    type CodecInput = NDBuffer | Buffer
         ^^^^^^^^^^
SyntaxError: invalid syntax

and lots more similar errors.

This occurs even if the only versions of Python on the system are 3.14
and 3.15.  Since 3.14 is the current default version of Python, this
upgrade will probably break every other package that depends on it, as
they will all fail if they try importing this package.

My suggestion is to downgrade this package back to the last version
supporting 3.14 (using version number 3.4.2+really3.3.7 or whatever),
and only upgrade to this version once Python 3.15 is the default
Python version, and also specify that this new package conflicts with
python3 << 3.15.

Best wishes,

   Julian

#1153075#10
Date:
2026-11-06 07:52:46 UTC
From:
To:

Sorry Julian but upstream zarr v3.4.2 'requires-python = ">=3.12"'.
Moreover, the fact that python-zarr is currently in unstable
demonstrates that it builds successfully at least with Python 3.14.

I cannot reproduce the issue on my side.
I just did a successful rebuild of the package on x86_64.
I double-checked that the build process involves both Python 3.14 and
Python 3.15.

Finally I tried to install python-zarr via apt and it works as expected.

Could you please provide more elements to reproduce the issue?

kind regards