#998680 coturn: does not work after boot, needs manual restart later

Package:
coturn
Source:
coturn
Description:
TURN and STUN server for VoIP
Submitter:
Axel
Date:
2026-09-05 22:39:01 UTC
Severity:
normal
#998680#5
Date:
2021-11-06 09:29:35 UTC
From:
To:
Dear Maintainer,

Coturn does not work (audio/video connections are not possible) when started as a service when the machine boots. After a manual restart, it works well.

#998680#10
Date:
2023-09-14 09:26:17 UTC
From:
To:
Here is what I see in coturn startup:


sep 13 10:25:51 darkstone turnserver[760]: 0: : NO EXPLICIT LISTENER
ADDRESS(ES) ARE CONFIGURED
sep 13 10:25:51 darkstone turnserver[760]: 0: : ===========Discovering
listener addresses: =========
sep 13 10:25:51 darkstone turnserver[760]: 0: : Listener address to
use: 127.0.0.1
sep 13 10:25:51 darkstone turnserver[760]: 0: : Listener address to
use: ::1
sep 13 10:25:51 darkstone turnserver[760]: 0: : ERROR: main: Cannot
configure any meaningful IP listener address
sep 13 10:25:51 darkstone systemd[1]: coturn.service: Scheduled restart
job, restart counter is at 5.
sep 13 10:25:51 darkstone systemd[1]: Stopped coturn.service - coTURN
STUN/TURN Server.
sep 13 10:25:51 darkstone systemd[1]: coturn.service: Start request
repeated too quickly.
sep 13 10:25:51 darkstone systemd[1]: coturn.service: Failed with
result 'exit-code'.
sep 13 10:25:51 darkstone systemd[1]: Failed to start coturn.service -
coTURN STUN/TURN Server.



The systemD service is looking at:

After=network.target

I wonder if changing that to :

After=network-online.target

would not resolve this issue

#998680#15
Date:
2026-09-05 22:37:50 UTC
From:
To:
I am experiencing the same problem.  My guess is the root cause is that coturn
is trying to start too quickly, before the network interface has been brought
up.  The fix is probably to add a service dependency so that everything that
is needed is up before it tries to start.

#998680#18
Date:
2026-09-05 22:37:50 UTC
From:
To:
I am experiencing the same problem.  My guess is the root cause is that coturn
is trying to start too quickly, before the network interface has been brought
up.  The fix is probably to add a service dependency so that everything that
is needed is up before it tries to start.